User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: heater fault on vectra c

  1. #1
    New Member
    Join Date
    Feb 2010
    Location
    WEST MIDS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default heater fault on vectra c

    hiya im new to this site i hope some one can help me out ive just bought the vectra with this problem ive changed the resister and the control panel twice to be sure the new ones werent at fault the heater only works on setting 4 ive ran out of ideas now as i was told these were the 2 most common i hope someone as the answer for me thanx daron

  2. #2
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    normaly its the resistor or fans can sieze up

  3. #3
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    - usually if the fan begins to seize it blows the fuse.

    Does the fan sqeak and make funny noises when u 1st turn it on?

    Have u tried taking the pollen filter out and spinning the fan by hand?

    You might need a new motor

  4. #4
    Regular Member
    Join Date
    Feb 2008
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    http://www.vectra-c.com/forum/showthread.php?t=99565

    similar fault to what i have? but have not got round to fixin it

  5. #5
    Regular Member
    Join Date
    Mar 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi, if you take out your glove box and look up under the dash the side nearest the wing of the car you will see a blue small relay change it and i think you will be plesantly suprised and you will like hippo`s as much as i do.......

  6. #6
    New Member
    Join Date
    Feb 2010
    Location
    WEST MIDS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanx guys i will try changeing the blue relay fingers crossed ps ive taken the pollen filter out motor spun freely no noise either when you switch on no 4, is there only the one blue relay under the glove box thanx again daron will let you know how i get on

  7. #7
    New Member
    Join Date
    Feb 2010
    Location
    WEST MIDS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    me again also the chap i bought the vectra off says the car as been serviced but only one stamp in the book asked vaux they said they couldnt help me to trace where the car had been done any ideas ps the car is a vaux vectra 2-0 cdti 2003 elegance model thanx again daron

  8. #8
    Regular Member
    Join Date
    Feb 2008
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    did you get round to sorting this sneady?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 52 vectra C GSi Heater fault
    By AOL in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 1st February 2010, 23:36
  2. heater fault ?
    By s9aln in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 16th September 2008, 19:17
  3. 2002 52 vectra C GSi Heater fault
    By AOL in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 29th December 2007, 17:02
  4. Heater Fault
    By suj786 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 17th November 2005, 13:49

Visitors found this page by searching for:

small blue relay in glovebox vectra c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •