User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: help needed on blowers and leak....

  1. #1
    Regular Member bobby-tupper's Avatar
    Join Date
    Nov 2008
    Location
    LEEDS, W.YORKS
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default help needed on blowers and leak....

    have be asked by a woman i know for some advice on her poorly vec c 1800 52 reg, problem 1, the nsf footwell carpet is all wet and windows badly condensated,??
    problem 2, the blowers only work on speed 4? and the heater doesnt seem to be getting warm???

    have looked on the search part and not really found much info,
    the car has not had the windows left down or the car is not using and water,so dont think the heater matrix could have gone.
    all ideas welcomed

  2. #2
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Drain plug near the pollen filter is blocked, so water has built up, this has soaked the pollen filter (hence condensation), and the water has leaked through to the fan behind the glovebox, causing it to lose speeds 1-3.

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    What Jezzy said while I was busy typing this lot...

    There's definitely stuff on here about this sort of thing, but searching can be an art in itself...

    Sounds like the water drain by the pollen filter has got blocked so water has gone through the pollen filter into the fan - so damaging the electrics - and then down into the floor - so making the carpet wet.

    Lift up the bonnet and pull the rubber seal of the nearside half of the bulkhead and lift up the flap to access the pollen filter. If the rubber drain is blocked up, this could be your problem.

    You need to remove all of the mud and leaves that has built up in this area behind the bulkhead - most of the surface in there should be paint coloured but is probably a brown-ish mix of mud and leaves.

    Be sure to clean out the rubber drain at the bottom all the way through (it goes down a few inches). Wash it out with water at the end and make sure the water goes down the drain hole and not through the pollen filter.

    Finally, replace the pollen filter as that will be ruined.

    You'll then need to get the fan repaired and I don't know much about that so hopefully someone will be along who knows about diagnosing it and (probably) replacing the resistor pack.

  4. #4
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I practice the art of typing quickly, keeping thinking to a minimum.

  5. #5
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Jezzy View Post
    I practice the art of typing quickly, keeping thinking to a minimum.
    I don't think much - obviously need to work on the typing.

  6. #6
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default

    as james said you will have to replace the resistor as well bud
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  7. #7
    Regular Member bobby-tupper's Avatar
    Join Date
    Nov 2008
    Location
    LEEDS, W.YORKS
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by chrisvectra View Post
    as james said you will have to replace the resistor as well bud
    where is the above? is there a how 2? and how much will it cost?

  8. #8
    Regular Member bobby-tupper's Avatar
    Join Date
    Nov 2008
    Location
    LEEDS, W.YORKS
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    have bought her a new resistor this morning from vx,but still unsure of its location,the pics on the other thread are unclear? can anyboby point me in the right direction when the glove box is removed??????

  9. #9
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by bobby-tupper View Post
    have bought her a new resistor this morning from vx,but still unsure of its location,the pics on the other thread are unclear? can anyboby point me in the right direction when the glove box is removed??????
    I've never done it myself but here goes...

    Remove the glovebox, the passenger footwell trim (centre console side) and then the passenger footwell air vent pipe. You may get away with just removing the glovebox but might need to remove the pipe and trim for better access.

    Disconnect the wiring plug from resistor pack behind where the glovebox was. There are 2 wiring connectors - one with 2 wires (which plugs into the motor) and one nearby with about 4 wires - you want the one with about 4 wires.

    The resistors are right under the wiring connector you have just removed - slide the resistor pack towards the centre of the car until the tabs on it align with the slots on the case then pull it out.

    Fit the new resistor pack then the wiring connector and then check all fan speeds work before putting everything else back together.

    Hopefully someone who has actually done this can provide more info and maybe some pics.

  10. #10
    Regular Member bobby-tupper's Avatar
    Join Date
    Nov 2008
    Location
    LEEDS, W.YORKS
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by James24 View Post
    I've never done it myself but here goes...

    Remove the glovebox, the passenger footwell trim (centre console side) and then the passenger footwell air vent pipe. You may get away with just removing the glovebox but might need to remove the pipe and trim for better access.

    Disconnect the wiring plug from resistor pack behind where the glovebox was. There are 2 wiring connectors - one with 2 wires (which plugs into the motor) and one nearby with about 4 wires - you want the one with about 4 wires.

    The resistors are right under the wiring connector you have just removed - slide the resistor pack towards the centre of the car until the tabs on it align with the slots on the case then pull it out.

    Fit the new resistor pack then the wiring connector and then check all fan speeds work before putting everything else back together.

    Hopefully someone who has actually done this can provide more info and maybe some pics.
    thanks james.
    can anybody else tell me if this is about right??? plse

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil Leak+Clutch+DMF - Advice Needed Please
    By bigade1 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 24th April 2012, 20:54
  2. Help needed with leak on signum :( (with pics)
    By Shogun in forum Bodywork & Interior
    Replies: 26
    Last Post: 8th November 2011, 14:26
  3. Help needed Vectra oil leak
    By tunnafish in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 16th July 2011, 09:32
  4. oil leak help needed
    By b3kaw in forum Engine & Drivetrain
    Replies: 3
    Last Post: 15th March 2010, 20:55
  5. oil leak help needed
    By ditchp in forum Engine & Drivetrain
    Replies: 12
    Last Post: 27th September 2007, 07:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •