User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Could this be injector seals or??

  1. #1
    New Member
    Join Date
    Sep 2009
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Could this be injector seals or??

    Hey guys,

    I need to pick your brains...

    I have an 05 1.9CDTI (150) sxi vectra. I have recently replaced the leak-off pipe to try and solve this problem but i am still having some issues.

    First thing is the car produces a lot of white smoke on start (with smell) - not sure if this is related to outside temp. It will sometimes start and the spanner light will come on and stay on; the car then is in limp mode (i assume; def not running on all cylinders). If i switch it off and restart the light will be on and then go out and car will run on full cylinders ok. The other thing is that the 'rev counter' (not sure of the technical name ) jumps about a bit at times when sitting at idle - at a junction or something.

    I had these problems before except the car would have cut out at times so i had the leak off pipe replaced and it hasnt cut out since but the other probs are still there. (i've also had the 3rd injector wiring replaced about 6 mnths ago with the field kit thing)

    Is this a problem with injector seals? or the injectors themselves or somthing else? The guy i get to look at the car is stumped and i would rather not replace things that don't need it! Times are tough and all that

    Any help would be much appreciated!!

    Cheers.

  2. #2
    New Member
    Join Date
    Sep 2009
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just an update on this.

    I put a cable ties around all of the injectors and the spanner light has since cleared completely.

    I'm still getting a bit of hesitation when driving at times but i think this might be EGR related so ill get it checked at some stage.

  3. #3
    Regular Member Zampus's Avatar
    Join Date
    Feb 2010
    Location
    Cantabria (Spain)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by gmclorn View Post
    Hey guys,

    First thing is the car produces a lot of white smoke on start (with smell) - not sure if this is related to outside temp. It will sometimes start and the spanner light will come on and stay on; the car then is in limp mode (i assume; def not running on all cylinders). If i switch it off and restart the light will be on and then go out and car will run on full cylinders ok. The other thing is that the 'rev counter' (not sure of the technical name ) jumps about a bit at times when sitting at idle - at a junction or something.

    Cheers.
    Same things happened in my vec. Changed the 3rd injector wiring and problem solved.

    http://www.vectra-c.com/forum/showthread.php?t=73584

  4. #4
    New Member
    Join Date
    Sep 2009
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah i've had this mod done already. I dont know if it was just a lose connection on one of the other connectors... hopefully that'll be that problem sorted! one down, another ten to go!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 dti injector seals
    By Al 22 dti in forum Engine & Drivetrain
    Replies: 3
    Last Post: 29th September 2012, 16:45
  2. Injector seals 2.0 Dti
    By bigmac in forum Engine & Drivetrain
    Replies: 51
    Last Post: 9th October 2010, 09:32
  3. Injector seals
    By suggs1971 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 3rd February 2010, 22:02
  4. Injector seals!!
    By siz1 in forum Engine & Drivetrain
    Replies: 27
    Last Post: 13th October 2009, 19:20
  5. injector seals
    By tditony in forum Troubleshooting
    Replies: 4
    Last Post: 6th May 2009, 20:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •