User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: new alternator but still battery light for 2mins?

  1. #1
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default new alternator but still battery light for 2mins?

    hi after my battery light comin on along with my abs/tc/esp light i changed my alternator.

    I changed it and the battery voltage soon went op to 14v but every moring my battery light comes back on for 2 mins then goes? only does it first start onf the day?

    dtc is p0621-02?

    Battery voltage is 12.5v before the first start and then 11v. the battery doest seem to charge straight away but after a few minutes of driving and the battery will quicky rise to 14v? does this sound like a faulty alternator again? its a lucas re-manufact.

    I thinkforgot to disconect the battery when i took the old alternator off and got a spark from some where? (had been a long day) could this have damaged my ecu/cim?

  2. #2
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)

    Default

    P0621 generator control lamp arrangement dysfunction IPC (instrument) C-021

    Faulty clocks maybe ?

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    faulty clocks? that would be the iceing on the cake!

  4. #4
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)

    Default

    Not sure but IPC is instruments which is Clocks,wait till some one else post before you take my advise

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  5. #5
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    its going in for a startor motor at dealers soon so ill get them to investigate if i cant sort it, but would like to sort it out my self first really?

  6. #6
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    anyone else have any ideas what p0621 Generator Lamp "L" Control Circuit Malfunction
    is and a possible fix? after reading old threads doesnt look like anyone knows

  7. #7
    Regular Member
    Join Date
    Sep 2008
    Location
    leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi Craig,

    This happens if you fit the wrong alternator. On older types the L circuit was simply connected straight to the warning lamp. On a Canbus car it goes to the ECU which controls the warning light. I am guessing your alternator does not comply with Canbus.

    This is a known problem when fitting an aftermarket alternator. Not all of them are correctly listed!

    Hope this helps
    David.

  8. #8
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by davidj387 View Post
    Hi Craig,

    This happens if you fit the wrong alternator. On older types the L circuit was simply connected straight to the warning lamp. On a Canbus car it goes to the ECU which controls the warning light. I am guessing your alternator does not comply with Canbus.

    This is a known problem when fitting an aftermarket alternator. Not all of them are correctly listed!

    Hope this helps
    David.
    it doesnt do it all the time tho?

  9. #9
    Regular Member JonV6's Avatar
    Join Date
    Mar 2008
    Location
    Cardiff
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Craig1985 View Post
    it doesnt do it all the time tho?
    That's CANBUS for you, intermittent city!!!

  10. #10
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    are alternators connected to the canbus sytem? i only have a thick brown and a thin blue? im getting 14.2 from the blue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 18th August 2012, 08:58
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Red Battery Light: Suspected Failed Alternator - DIY or Garage?
    By samlawrence in forum Engine & Drivetrain
    Replies: 1
    Last Post: 10th August 2011, 20:27
  4. battery light on, alternator not charging, aarggh!!
    By valvelift in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 26th June 2011, 17:33
  5. Alternator/Battery Dash Warning Light
    By cavester in forum Troubleshooting
    Replies: 31
    Last Post: 1st June 2011, 08:24

Visitors found this page by searching for:

changed altenator on vectra but battery light is still on

Generator Lamp L Control Circuit Malfunction

vauxhall insignia battery light on

vectra c dti battery light on

2010 vauxhall insignia 2.0 cdti alternator charging but battery light on

generator lamp l control circuit malfunction ipc

https:www.vectra-c.comforumshowthread.php100926-new-alternator-but-still-battery-light-for-2mins

insigna alternater light

alternator malfunction lamp l

generator control lamp arrangement dysfunction ipc

Generator Lamp L Control Circuit Malfunction IPC (Instrument) C-021 

2006 vectra generator lamp l control circuit malfunction ipc (instrument) c-021

vauxhall insignia changed alternator but battery light comes on

vectra c battery light on

p0621-02 generator lamp l control circuit malfunction

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •