User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: 2.2 DTI Temperature problems

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    hinckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 DTI Temperature problems

    Just a quick note for anybody with a 2.2 DTI that doesn't reach the correct temp, i've found loads of threads about the CDTI's having termostat problems but nothing about the DTI's. i was having the same problem as many of the CDTI owners were having, so i decided to replace the thermosat to see if it cured it, and it did. before the temp gauge would barely move on the motorway, now sits between 85 - 90 degrees.

  2. #2
    Regular Member
    Join Date
    Sep 2009
    Location
    warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default dti sri thermostate

    i have got the same problem with my dti. did you fit a vx thermostate. or a after market one.

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    hinckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah fitted a genuine vx one. less that 50 quid with the gasket

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Temperature help!!
    By Lex82 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 21st July 2012, 15:14
  2. Temperature
    By Wolfie01 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 13th February 2012, 10:34
  3. crusie control problems, anyone had similar problems?
    By rozzer2006 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 2nd October 2011, 21:20
  4. Temperature problems?????
    By vx sri in forum Vectra C / Signum Troubleshooting
    Replies: 9
    Last Post: 19th April 2011, 00:40
  5. engine temperature / boost / hub problems
    By rickyroo in forum Engine & Drivetrain
    Replies: 5
    Last Post: 24th September 2007, 18:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •