User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: HELP!! Mabye I'm pannicking

  1. #1
    Regular Member mickg's Avatar
    Join Date
    Dec 2009
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation HELP!! Mabye I'm pannicking

    Hello there. On the way back from work today I just noticed some strange sounds comming from front left wheel. When I'm turning stering wheel I can hear sound like this " klong klong". Just when I'm making a turn. Just don't know what it can be... hopefuly nothing serious and costful ;/
    Ohh... and one more thing when I'm staring engine and it's cold or dumpy weather it makes some squicky sound " twi ti ti twi..." I'm worried about that as well... Any ideas?
    Thanks

  2. #2
    Regular Member Danialj32's Avatar
    Join Date
    Sep 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by mickg View Post
    Hello there. On the way back from work today I just noticed some strange sounds comming from front left wheel. When I'm turning stering wheel I can hear sound like this " klong klong". Just when I'm making a turn. Just don't know what it can be... hopefuly nothing serious and costful ;/
    Ohh... and one more thing when I'm staring engine and it's cold or dumpy weather it makes some squicky sound " twi ti ti twi..." I'm worried about that as well... Any ideas?
    Thanks
    Could be wrong here, but klonk noise could be drop links, and engine noise could be cam belt! Pretty sure someone will 'firm it for ya!

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As above check drop links & also check the springs incase 1 has snapped

  4. #4
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by dh.dti View Post
    As above check drop links & also check the springs incase 1 has snapped
    agreed - or might just be the spring moving in its seat

    0-Large smile ......every time it's driven

  5. #5
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by mickg View Post
    Ohh... and one more thing when I'm staring engine and it's cold or dumpy weather it makes some squicky sound " twi ti ti twi..." I'm worried about that as well... Any ideas?
    Thanks
    Replace the aux-belt.

  6. #6
    Regular Member redraptor_141's Avatar
    Join Date
    Nov 2008
    Location
    Sailing the High Seas on HMS Ark Royal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    clonking could be anything! its taken me two years to get mine down to what it is.


    first check the drop links as previously said if there stiff or rusted up get them changed. its a cheap part and you only need two spanners to do it! £15 from eBay if i remeber (just give them a wiggle from side to side and they should move all right and the rubber around the joints should be all nice and not ripped)

    Secondly it might be your front ARB bushes are worn. basicly letting the ARB (Anti Roll Bar) move about these are again a cheap part and there is a handy How2 on here if you need it.

    Thirdly jack the car up and give the springs a good feel up see if you can feel any damage (they are remound for going) mines gone big time before they usually snap at the base of the spring from what i can gather. these are £100 from the stealers but you can get them of eBay dirt cheap. both sides should be done tho if this is the case. also check on the base of the spring has got the rubber/plastic sleave on as this was a vauxhall applied mod on later vecs. if not this is a cheap part im led to belive.

    Fourthly! if its a clonking when turning at slow speeds it might be the suspention top mount has some wear (this is whats up with mine) in which case its nothing to worry about in the short term. its basicly a plastic baring that allows the spring to move when turning and such. its just when the clonking goes to a twanging noise you really need it done as the spring will be coiling itself then releaseing. there about £15 from vaux. if you can disasemble the strut yourself do it and labour will be lots as it means removing the suspention!

    id suggest if the strut has to come out for any reason you might as well get them/you to have a look at the ARB bushes and the drop links as well as they are as ive said very cheap and while its off you might as well get them replaced if they look like there going any time soon!!


    Hope this helps lol ive had no end of sqeeks and rattles and clonks coming from the front end!! Eibachs and bilstens have sorted that tho. just regret not replacing the top mounts while they were off!!!!




    oh yeaah the sqweeky sound will most likly be the aux belt slipping on the engine. easy fix cheap part. you allways hear cars sqeeling down the road with a worn belt on!

  7. #7
    Regular Member mickg's Avatar
    Join Date
    Dec 2009
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok guys thanks very much for your response. I will check m 'babe" today unles it will be rainning. I will jack it up and check. By the way the noise is on a slow speed.
    thanks one more time. I will let u know whats happened.

  8. #8
    Regular Member parsco's Avatar
    Join Date
    Sep 2008
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I was always under the impression that if there is clunking while turning at low speed then you are looking at a new drive shaft?

  9. #9
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    34 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    parsco in some carse it is i always thought the sme but its when you put full lock on
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  10. #10
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    OK you don't say what engine you have, nor is it in your personal info, so on experience i will guess its a 2.0 / 2.2dti? may be wrong but you are describing the twi - twi of the serpent belt??,(the long flat belt) Get some nylon + rubber lubricant spray from halfords, squirt ONLY! the ribbed side of the belt NOT THE SMOOTH SIDE!!!, As for the clunking does it clunk clunk in time with the wheel speed turning??, or is it a bit more like clunking when generaly turning or going over speed humps??, you can always pm with more info.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I know mabye it will sound silly... but what colour is my car?
    By mickg in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 6th June 2010, 19:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •