User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: possible suspension problem?

  1. #1
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default possible suspension problem?

    Firstly, I'm not sure if this is all in my head or not. I've spent the entire snowy period riding around in my wife's CRV with big tyres and 4x4 suspension.

    It just seems the ride on my facelift SRi seems a lot harsher now. Like if I hit even shallow potholes, there is a loud BANG from the wheels. Its like the tyres are over inflated and rock solid (they're not). Also, I've found if I go over a series of bumps it feels like the backend is almost loosing grip and wants to kick out from behind me.

    I'm going to service my car today and so will check the springs, any ideas what else I could check?

    Cheers

  2. #2
    Regular Member BigWilko's Avatar
    Join Date
    Jan 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 3.0 CDTI

    Year : 2005

    Default

    Can't help you with this thread mate but i'll keep my eye on it as i think i have the same problem. At first i thought it might just be the parcel shelf bouncing around whilst going over bumps but like you say, that wouldn't cause the back end to wave around. Let us know how the service goes and if you find anything.

  3. #3
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Have you guys had the upper control arms replaced? Sounds very much like the problem

  4. #4
    Regular Member BigWilko's Avatar
    Join Date
    Jan 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 3.0 CDTI

    Year : 2005

    Default

    No mate, I only had my 54 ls 2 weeks so it's still under the used car 3 month warranty, so i'll talk to them about it. cheers for the info

  5. #5
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    service on hold for now as I can't get the ****** sump plug out. Had a quick look at the two front springs and they look fine. Will have a look at the rear springs once I've finally been able to drop the oil

  6. #6
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    Have you guys had the upper control arms replaced? Sounds very much like the problem
    Not to my knowledge. looking at them on ebay, are they handed or as N/S & O/S identical?

    http://cgi.ebay.co.uk/ws/eBayISAPI.d...m=160352026771

  7. #7
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Identical mate

  8. #8
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Run your fingers around the bottom of the rear springs, its not un- common for the little piggy tail of the spring to snap off!.

  9. #9
    Regular Member
    Join Date
    Jan 2010
    Location
    Newcastle upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check the anti roll bar rubbers too. they wear and people, also garages miss these. They make an awful racket when worn

  10. #10
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is it possible to visually identify if the ARB or upper control arm bushes are shot without removal? Would like to identify what needs replaced before ordering parts if possible.

    I had the front end up earlier this week. Will see if I can get time to get the rear end off the ground on Tuesday. Need to invest in ramps soon, getting fed up jacking the car up lol

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Suspension problem
    By Fishmichael in forum Suspension, Wheels & Brakes
    Replies: 12
    Last Post: 11th January 2011, 21:29
  2. Suspension problem?
    By tony-1977 in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 13th December 2010, 18:15
  3. another rattling suspension problem
    By kalim in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 11th January 2010, 20:46
  4. Possible Shock/Suspension Problem?
    By Mazzy in forum Suspension, Wheels & Brakes
    Replies: 4
    Last Post: 2nd February 2009, 15:01
  5. HELP! front suspension problem
    By pinoy in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 25th March 2006, 10:15

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •